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1

Installing Saber

This document describes how to install Saber. It includes instructions for
installing the Saber simulator, Saber HDL, and design environment on UNIX,
Linux, and Windows platforms. Several other tools, including the CosmosScope
waveform analyzer install with the Saber simulator.

This document includes the following sections:

Preparing for Installation

Synopsys Common Licensing (SCL)

Installing the Software on UNIX, Linux, and Windows
Invoking Saber on Windows

Setting Up the User Environment on UNIX and Linux
Verifying the Saber Installation on UNIX and Linux
Using Command Line Options

Uninstalling the Software

Customer Support

Important:

Install the latest version of Saber in a folder that does not contain an existing
installation. A common license can serve multiple versions of Saber.

The installation instructions in this document are the most up-to-date
available at the time of production. However, changes might have occurred.
For the latest installation information, see Saber release notes or
documentation on SolvNet at http://solvnet.synopsys.com/.
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Preparing for Installation

Preparing for Installation

The following points are prerequisites for the installation process.

If you have not already done so, retrieve your license keys from the
SmartKeys Web page at
http://solvnet.synopsys.com/smartkeys

For detailed licensing information, see the Synopsys Licensing QuickStart
Guide Web page at
http://www.synopsys.com/keys

See the Supported Environments section in Saber release notes for
information on supported platforms. Saber release notes are available at
https://solvnet.synopsys.com/ReleaseNotes. For information on accessing
SolvNet see the Accessing SolvNet section.

UNIX and Linux users: You must have root or administration privileges when
installing licensing or tools in a restricted directory location. The installation
script requires that the Bourne shell is available at /bin/sh.

Windows users: You must have administration privileges for installing and
uninstalling the tool. In addition, you must close all running Saber
applications (Sketch or Saber) before starting any Saber installation
processes on Windows.

To download the software by electronic software transfer (EST), you must
have Netscape Navigator 4.0 or later, Microsoft Internet Explorer 4.0 or later,
or Mozilla 1.x or later.

Verify that your disk space is adequate. See Table 1 on page 5 for
information on disk space requirements for each platform.

By default, the interface files that support MATLAB version 7.0 SP2 are
installed. When you set the PATH environment variable, put the value for
MATLAB in front of the other values. For example,

\o

> PATH = C:\Program Files\MATLAB7.0\bin\win32; \
C:\synopsys\version\ai bin

For access to other versions of MATLAB, see the INSTALL_README.wri

file. For instructions about setting up other optional software (Cadence,

Mentor, ModelSim, Verilog) see the Installing Saber Frameways and Co-

Simulation Interfaces chapter

The Saber Release Notes provides information about changes in licensing,
memory requirements, and supported platforms, as well as other
enhancements and changes regarding the Saber tool.

Saber® Installation Guide
B-2008.09-SP1



Chapter 1: Installing Saber
Synopsys Common Licensing (SCL)

To read the release notes,

1.

Go to https://solvnet.synopsys.com/ReleaseNotes (If prompted, enter your
user name and password. If you do not have a Synopsys user name and
password, follow the instructions to register with SolvNet.)

Click Saber, then click the release you want in the list that appears at the
bottom.

The Release Notes are in Portable Document Format (PDF) and require a PDF
file reader to view and print them.

Note:

To view and print Saber documentation in Portable Document Format
(PDF), you must have Adobe Acrobat Reader installed on your machine. To
acquire the latest version of the Adobe Reader software, free of charge, go
to http://www.adobe.com/ and click the Get Adobe Reader button. Follow
the instructions on the Web page.

The following sections describe:

Disk Space and Memory Requirements

Installing the Software on UNIX, Linux, and Windows
Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Synopsys Common Licensing (SCL)

Uninstalling the Software

Customer Support

Synopsys Common Licensing (SCL)

Synopsys Common Licensing (SCL) provides a single method of obtaining
licenses used by all Synopsys tools. SCL reduces licensing administration
complexity, minimizing the effort you expend in installing, maintaining, and
managing licensing software for Synopsys tools.

Note:

For information on the latest version of SCL supported by Saber, see the
Saber Release Notes. The latest versions of Saber Release Notes are
available on SolvNet at http://solvnet.synopsys.com.

Saber® Installation Guide 3

B-2008.09-SP1


http://solvnet.synopsys.com

Chapter 1: Installing Saber
Synopsys Common Licensing (SCL)

Installing, Administrating, and Troubleshooting SCL

For information on installing, administrating and troubleshooting SCL see the
Synopsys Licensing Quick Start Guide at http://www.synopsys.com/support/
keys/keys.html. The Synopsys Licensing Quick Start provides information on
Downloading & Installing SCL, and other information that is necessary to
administrate and trouble shoot SCL.

The Documentation section provides links to the installation readme, release
notes, administration guide and the FLEXnet User Manual.

Note:

Install a single copy of SCL on your license server to be used with all
Synopsys tools. Installation of Synopsys tools and SCL is not order
dependent. That is, you can install SCL before or after you install your
Synopsys tools. However, you cannot use any Synopsys tools reliant on
SCL until you have installed and configured SCL.

SCL Documentation

The Synopsys Common Licensing Installation Notes, Synopsys Common
Licensing Release Notes, and the Synopsys Common Licensing Administration
Guide, are also available in PDF format in the SCL installation directory at
scl root/docs.

The FLEXnet End Users Guide and FAQ is also available in PDF format in the
SCL Installation directory at docs\ flexlmman.

The following sections describe:

Disk Space and Memory Requirements

Installing the Software on UNIX, Linux, and Windows
Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Synopsys Common Licensing (SCL)

Uninstalling the Software

Customer Support
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Disk Space and Memory Requirements

The disk space requirement varies depending on the platform and the features
selected for installation. Table 1 shows the maximum space required for
installing all Saber features on a particular platform. Each CD also includes this
information in the top-level INSTALL_README.wri file.

Table 1 Saber Disk Space and Memory Requirements (in Megabytes)

Platform Software Default temporary directory Temporary disk Temporary disk
(maximum) location space from CD space from EST
Sun Solaris 1470 /var/tmp 400 400
Linux 1500 /tmp 390 390
Windows 1310 % TEMP% 365 365
or
%HOME%\Local
Settings\Temp

The following sections describe:

Installing the Software on UNIX, Linux, and Windows
Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Synopsys Common Licensing (SCL)

Uninstalling the Software

Customer Support
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Installing the Software on UNIX, Linux, and Windows

You can install Saber and Saber HDL using the common install GUI. To install
Saber by using text commands, see Installing Synopsys Tools, available at
http://www.synopsys.com/install

The following sections describe:
Installing the Software by EST
Installing the Software From a CD
Running the Installation Program

Installing the Software by EST

Download the Saber release to a temporary directory. You can obtain the latest
Saber download instructions from the Release Library, which is accessible
through SolvNet.

To install the software on UNIX and Linux systems,

1. Double-click the downloaded file, or enter the file name at the command
prompt.

2. Continue with the steps in Installing Synopsys Tools.
To install the software on Windows systems,
1. Locate and double-click the .exe file. For example, double-click

Saber version win.exe
where version is the release you are installing.

2. Continue with the steps in Installing Synopsys Tools.
The following sections describe:

Installing the Software From a CD

Running the Installation Program

6 Saber® Installation Guide
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Installing the Software From a CD

Mounting the CD might require root access privileges. If you do not have root
access privileges, see your system administrator for instructions on mounting
the CD. For detailed instructions, see Installing Synopsys Tools.

To mount the CD on UNIX and Linux systems,

1.

or

3.

Place the CD in the CD drive.

Most UNIX and Linux systems will automatically mount the CD. If the CD
does not mount, see Installing Synopsys Tools.

To invoke the installer, enter

% /cdrom/saber version platform.bin

% cd your cd path; ./saber version platform

Continue with the steps in Installing Synopsys Tools.

To mount the CD on Windows systems,

1.

2.

Place the CD in the CD drive.

The installation program should start automatically. If it does not, double-
click the setup.exe executable file, located at the root level of the CD. For
example,

D:\saber version win.exe

where D is your CD drive.
Continue with the steps in “Running the Installation Program,” next.

The following section describes:

Running the Installation Program

Saber® Installation Guide
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Running the Installation Program

Make certain that any open applications are closed before proceeding with the
installation. Also, consider disabling virus checking for the duration of the
installation process, because virus checks can slow the installation process.

When the installation program begins, the Welcome screen appears. Answer
the installation prompts and click Next to continue. If scroll bars appear in the
panel, scroll to make sure you have reviewed all available information.

Only the path destination screen, which requires more explanation, is shown.
(Note that selections shown in this screen are for demonstration purposes only
and might not reflect the current product version.)

1.
2.

Read the Welcome Screen.

In the Installation Type window, select the type of installation you want to
perform.

UNIX and Linux: Select a Typical or Custom installation.

Windows: Select a Typical or Custom installation, or select a Network
installation to establish network access from a client machine to previously
installed products on a remote machine.

If you selected a Typical or Custom installation, enter a directory name that
does not include spaces in the Destination box. You can also use the
Browse button to select a directory.

(Windows only) If you have chosen to perform a network installation, create
a network mapped drive to a remote machine on which the Saber software
was previously installed. If not, skip to step 6.

(Windows only) Set up network access to a remote machine.

The Network installation option allows you to link to Saber applications,
which are installed on other Windows machines. It is assumed that a stand-
alone Saber installation has already been performed on that machine.

Using Saber via a network installation is slow and results in poor
performance when compared to a local installation.

Saber® Installation Guide
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* Enter the source path by using the previously created mapped drive,
which resolves to the location where the ai_bin directory is located. For
example,

S:\Synopsys\B-2008.09-SP1
where S: is your network mapped drive.

* Enter a destination path name to a location on the local host machine
where a minimal set of files will be installed. In the Browse window,
navigate to the directory you want, for example, B-2008.09-SP1. Select
this directory and click the Open button. The path to the B-2008.09-SP1
directory is inserted in the Source box.

£ Saber(R) B-2008.09-5P1

Click Mextto accept the Destination directory path farvour Saher® installation.

To choose a different installation directory, type a new Destination path or click the
Browse button.

Destination: |CASynopsystB-2008.09-5F1 |

Browse

< Back Cancel

6. If you selected a custom installation, select the Saber features you want to
install.

Saber® Installation Guide 9
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7. You will see a screen that asks you to wait while the disk space is being
verified. Then the summary information screen appears. This screen
summarizes the selections you have made and the disk space
requirements.

8. Wait while the products are installed.

While files are being copied, you can track the Installation progress in the
progress bar. When the bar shows a 100 percent progress, a Release Notes
dialog box opens. Click Yes to read the release notes, click No to continue.
You must wait while the uninstall program is created. The final installation
status is then displayed, with the message that the tool has finished
installing.

If errors are displayed in the final installation status, see the install log for
details.

9. Click Finish to exit the installation program.
The following sections describe:

Invoking Saber on Windows

Invoking Saber on UNIX and Linux

Synopsys Common Licensing (SCL)
Uninstalling the Software

Customer Support

Invoking Saber on Windows
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Beginning in December 2005, regardless of which version of Saber you are
installing, you must use Synopsys Common Licensing 10.9.1 or later, which
requires only a single license daemon, snpslmd. For additional information,
see Installing Synopsys Tools.

To run Saber on Windows platforms,

1. Check that your SNPSLMD LICENSE FILE, LM LICENSE FILE, Of
another tool-specific license variable is set to a valid licensing server. If
licenses are not available, the Saber Simulator will fail when invoked.

The port and host name variables correspond to the TCP port and license
server host name specified in the SERVER line of the Synopsys license file.

Saber® Installation Guide
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Each license file can contain licenses for many packages from multiple
vendors. You can specify multiple license files by separating each entry with
a semicolon (;).

2. Start the tool by going to Start > Programs > Synopsys > Saber version >
Saber Simulator.

The Saber window opens.

3. To check the product version, choose Help > About Saber, and in the
window that opens, click Copyright/Legal, then scroll to the bottom of the
screen to view the version.

4. To exit Saber, choose File > Exit.
The following sections describe:
Invoking Saber on UNIX and Linux
Synopsys Common Licensing (SCL)
Uninstalling the Software

Customer Support

Invoking Saber on UNIX and Linux

This section explains how to invoke Saber on UNIX and Linux. The following
sections describe:

Setting Up the User Environment on UNIX and Linux
Specifying the Executable File Location

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE Environment
Variable

Verifying the Saber Installation on UNIX and Linux
Using Command Line Options

Saber® Installation Guide 11
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Setting Up the User Environment on UNIX and Linux

To set up the user environment, you must specify the location of the executable
files and set the license environment variable.The directory containing the
executable commands is located within the ai_bin directory in the install_home
installation root.

The following sections describe:
Specifying the Executable File Location

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE Environment
Variable

Verifying the Saber Installation on UNIX and Linux
Using Command Line Options

Specifying the Executable File Location
To set up a new Saber user, add the executable file to the path.

® |f you are using the C shell, add the following line to the .cshrc file:

setenv PATH install home/ai bin:$PATH
® |f you are using the Bourne, Korn, or Bash shell, add the following line to the
.profile, .kshrc, or .bashrc file:

PATH=install home/ai bin:$PATH
export S$PATH

The following sections describe:

Setting the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE
Environment Variable

Verifying the Saber Installation on UNIX and Linux
Using Command Line Options

Saber® Installation Guide
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Setting the SNPSLMD_LICENSE_FILE or
LM_LICENSE_FILE Environment Variable

You must install the SCL software and define the SNPSLMD LICENSE FILE Or
LM LICENSE_FILE before you can verify the Saber installation.

For information about downloading and installing SCL and on setting the
license variable, see Installing Synopsys Tools.

The following sections describe:
Verifying the Saber Installation on UNIX and Linux
Using Command Line Options

Verifying the Saber Installation on UNIX and Linux
To verify the installation of the Saber tools,

1. Make sure you are in a directory where you have read/write privileges.
% cd $HOME

2. Invoke the tool by entering

)

% saber

or
% saberhdl

If the Saber tools are correctly installed, this command invokes the tool,
displays the welcome screen, then opens the tool.

The following section describes:
Using Command Line Options
Uninstalling the Software

Customer Support

Saber® Installation Guide 13
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Using Command Line Options

14

You can install Saber on UNIX and Linux platforms by using the setup script
command and on Windows platforms by invoking the setup . exe installation
program. By default, the Saber installer invokes the GUI installation program on
all platforms. If you want to install the software in silent mode or in the
background, use the -silent command-line option, which is supported on all
platforms. If you do not use the -silent option at the command line, any
option you enter is reflected in the GUI.

The following options are available from the command line. Unless otherwise
indicated, they are available for UNIX, Linux, and Windows systems.

Usage:setup [options]
-silent

Suppresses all graphics output. When you use the -silent option, Saber
is installed in the default directory, C:\Synopsys\version.

-installdir destination directory

Installs files to a destination directory. The path name cannot include
spaces.

-typical (default)
Installs typical features.
-custom all | featurel feature2

Select one or more features to install: Select one or more features to install:
SaberSimulator, SaberSketch, the Frameways for eProductsDesigner,
Cadence, MentorGraphics, and Zuken, CosmosScope, SaberHarness,
ComponentLibrary, and TemplateLibrary.

Frameway features (Cadence, eProductsDesigner,MentorGraphics, and
Zuken) might not be available on all platforms.

-is:tempdir temporary directory

Specify an alternative location in which to store temporary files. On UNIX
and Linux platforms, the default temporary directory might not contain
enough free space to install the tool, causing the installer to terminate
abnormally.

The following sections describe:
Uninstalling the Software

Saber® Installation Guide
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Customer Support
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Uninstalling the Software

To uninstall the software on UNIX and Linux,

= Execute the uninstall program, which is located in the Install_home/_Saber
directory, or delete the entire software directory.

If you delete the directory, you must also delete the vpd.properties file
located in your home directory.

To uninstall the software on Windows,

®  From the Control Panel, select “Add/remove programs.”
or

=  Choose Start > Programs > Synopsys > Saber version > Uninstall.
or

= Execute the uninstall program. For Saber, the uninstall program is located in
the Install_home\ Saber directory. For example,

c:> install home\ Saber\uninstall

The following section describes:
Customer Support

Customer Support

16

Customer support is available through SolvNet online customer support and
through contacting the Synopsys Technical Support Center.

Accessing SolvNet

SolvNet includes an electronic knowledge base of technical articles and
answers to frequently asked questions about Synopsys tools. SolvNet also
gives you access to a wide range of Synopsys online services, which include
downloading software, viewing Documentation on the Web, and entering a call
to the Support Center

To access SolvNet:
1. Go to the SolvNet Web page at http://solvnet.synopsys.com.

Saber® Installation Guide
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2.

If prompted, enter your user name and password. (If you do not have a
Synopsys user name and password, follow the instructions to register with
SolvNet.)

If you need help using SolvNet, click Help on the SolvNet menu bar.

Contacting the Synopsys Technical Support Center

If you have problems, questions, or suggestions, you can contact the Synopsys
Technical Support Center in the following ways:

1.

Open a call to your local support center from the Web by going to http://
solvnet.synopsys.com/EnterACall (Synopsys user name and password
required).

Telephone your local support center.
United States

Oregon office: 866-898-6700 or 503-547-6700, or send an e-mail message
to saber-hotline @ synopsys.com

International

Germany: Telephone +49-89-99-320-0, fax +49-89-99-320-117, or e-mail
saber-hotline-ge @ synopsys.com

France: Telephone +33 (0) 1 45 12 04 76,

fax +33 (0) 1 45 12 07 07, or e-mail
saber-hotline-fr@synopsys.com

Sweden: Telephone +46 08 555 20220, fax +46 08 55520249,
or e-mail saber-hotline-swe @ synopsys.com


http://solvnet.synopsys.com/EnterACall
http://solvnet.synopsys.com/EnterACall
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Installing Saber Frameways and Co-Simulation Interfaces

This document describes how to install the optional Saber tools in the following
sections:

Installing the Frameway Integration for Mentor Graphics

Troubleshooting a Frameway Integration for Mentor Graphics Installation
Installing the Saber Co-Simulation Interface With ModelSim

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Setting Up the Software to Use a Remote System

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation
Installing the Frameway Integration for eProduct Designer

Installing the Frameway Integration for Zuken CR-5000 System Designer

Installing the Frameway Integration for Mentor Graphics

This section describes how to install the Frameway Integration for Mentor
Graphics option, how to set up your environment, and what to do if problems
occur.

The Frameway Integration for the Mentor Graphics Falcon Framework is loaded
when you select MGC Frameway Integration on the installation tool menu as a
part of the software installation procedure.

For the Saber netlister to function, you must load the CDP package when you
install the Mentor Graphics software. The complete package name is

CDP V8 Ap SW

Saber® Installation Guide 19
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Note:

The SNPSLMD LICENSE FILE or LM_LICENSE FILE license variable
and the PATH environment variable must be defined before you run the
Frameway Integration or Co-Simulation Interface option.

% set PATH= (install home/ai bin $PATH)

where install_home is the path to the Saber home directory.

(For detailed instructions on setting the license variable, see Installing
Synopsys Tools, available at http://www.synopsys.com/support/installation/
install_guide.html.)

Installing the Software

To install the Frameway Integration for Mentor Graphics option,

1.

Verify that SMGC_HOME is set, and test the Mentor Graphics products:
Design Manager, Design Architect, and Design Viewpoint Editor.

* To invoke Design Manager, enter dmgr.
Exit Design Manager.

* To invoke Design Architect, enter da.
Exit Design Architect.

¢ To invoke Design Viewpoint Editor, enter dve.
Exit Design Viewpoint Editor.

Set up the Mentor Graphics gen_lib library.

a. Load the Mentor Graphics gen_lib library according to the instructions
provided by Mentor Graphics.

b. Direct the software to the library by using one of the following methods:

* Define MGC_GENLIB only in the location map file. Usually this definition

will have already been set as part of the Design Architect installation
procedure. For more information, see the Installing Mentor Graphics
Software manual.

* Include the location of the gen_lib library in the MGC_GENLIB

environment variable. If you set this environment variable, you can also
include an MGC_GENLIB entry in a location map file or not use a location
map at all.
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3. \Verify that the Saber simulator is installed and works correctly.
4. Load the Frameway Integration software.

If you did not load the Frameway Integration for the Mentor Graphics Falcon
Framework software at the time the Saber simulator was installed, do so
now.

5. Add the license information to the license file. If needed, install the licenses
for the Saber/Verilog Co-Simulation option and the Digital Simulation option.

6. Copy the Saber.dofile files and create symbolic links.

To take advantage of Design Architect and Design Viewpoint userware, you
must copy the .dofile file from the installation directory to the Mentor
Graphics MGC_HOME directory.

a. Make this location your current (working) directory. For example, on a
Sun system enter

% cd $MGC_HOME/shared/etc/cust

\

b. If the following directories do not already exist, create and change to
them:

o\°

mkdir dve
cd dve

o\°

o\°

mkdir userware
cd userware

o\°

o\°

mkdir En na

c. Create the following symbolic link:

)

% ln -s En na default

d. Copy the .dofile files by entering
% cp $install home/Saber/framework/falcon/ \
userware/dve/setup Saber.dofile default
e. Return to your home directory.

% cd

7. Create or modify environment variables in your startup file.

If you have scripts that automatically configure your environment, be aware
that they can overwrite some of the environment variables mentioned in this
step. You should place the variable declarations described in this step so
that they are executed last.
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To automatically set up your environment variables, use a text editor to
create the lines in your startup file.

UNIX: For the .cshrc file in the C shell,

* Enter the following lines in the .cshrc file after the setenv
install home and setenv MGC HOME variable definitions:

setenv SABER FALCON $install home/Saber/
framework/falcon

setenv AMPLE PATH $SABER FALCON/userware
setenv MGC TYPE REGISTRY $SABER FALCON/
saber rgy/registry/ \ N N
type registry/saber.rgy

setenv ANLG IPC PKG $install home/Saber/
framework/ \

falcon/ipc
setenv ANALOGY SABER available
setenv SABER MGC8 SYMBOLS $SABER FALCON/symbols

The order of these lines in your .cshrc file is important.
Note:

If AMPLE PATH exists, add $SABER_FALCON/userware to the colon-
separated list of paths. Typically, this path is placed at the end of the list,
but you must determine the appropriate order of the list (enter as all one
line). If MGC_TYPE REGISTRY already exists, just add
$SABER_FALCON/saber_rgy/registry/type_registry/saber.rgy to the
colon-separated list of paths. The following is an example of how these
would be listed in your .cshrc file:

setenv AMPLE PATH $AMPLE PATH:S$SABER_FALCON/userware
setenv MGC TYPE REGISTRYSMGC TYPE REGISTRY:S$SABER FALCON/ \
saber rgy/registry/type registry/saber.rgy

For the .profile file in the Bourne shell,

* Enterthe following lines in the .profile file after the install home and
MGC_HOME environment variable definitions:
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SABER FALCON="install home/Saber/framework/

falcon™"

AMPLE PATH="$SABER FALCON/userware"
MGC_TYPE REGISTRY="$SABER FALCON/saber rgy/

registry/ \

type

registry/saber.rgy"

ANGL IPC PKG="install home/Saber/framework/

falcon/ \
ipC n

SSABER FALCON/

ANALOGY SABER=available
SABER MGC8 SYMBOLS="$SABER FALCON/symbols"

export
export
export
export
export
export

SABER_FALCON
AMPLE PATH
MGC_TYPE REGISTRY
ANLG IPC PKG
ANALOGY SABER
SABER_MGC8 SYMBOLS

The order of these lines in your .profile file is important.

Note:

If AMPLE PATH or MGC_TYPE REGISTRY already exist, add the
paths specified above to the existing colon-separated list of paths.
For example, the previous AMPLE PATH and

MGC _TYPE REGISTRY entries could be replaced with the following:

AMPLE_PATH="$AMPLE_PATH:$SABER_FALCON/userware"
MGC TYPE REGISTRY="$MGC TYPE REGISTRY: \
$SSABER FALCON/saber rgy/registry/
type registry/ \
saber.rgy"

Windows: On Windows platforms, the Mentor environment variables
can be set either in the profile file or from the Start menu.

* Add the following lines to the profile.ksh file:

export ANALOGY SABER=available

export SABER FALCON=install dir/Saber/ \
framework/falcon

export AMPLE_PATH:$SABER_FALCON/userware

export MGC_TYPE_REGISTRY:$SABER_FALCON/saber_rgy/ \
registry/type registry/saber.rgy

export SABER_MGCB_SYMBOLS:$SABER_FALCON/Symbols

If AMPLE PATHOrMGC_TYPE REGISTRY is used for other applications,
add the Saber paths to these variables as follows:
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export AMPLE PATH="$AMPLE PATH; $SABER_FALCON/ \
userware"

export MGC TYPE REGISTRY="$MGC TYPE REGISTRY: \
SSABER_FALCON/saber rgy/registry/type registry/ \
saber.rgy"

MGC _TMPDIR=C: / tmp

ANLG IPC PKG=$ SABER_FALCON/ ipc

* Go to Start > Settings > Control Panel > System > Advanced tab >
Environment Variables. In the User Variable pane, click New and add
the following settings:

Variable name Variable value

ANALOGY_SABER available

SABER_FALCON install_dinSaber\framework\falcon

AMPLE_PATH %SABER_FALCON©%\userware

MGC_TYPE_REGISTRY %SAE:ER_FALCON%\saber_rgy\registry\type_registry\
saber.rgy

SABER_MGC8_SYMBOLS %SABER_FALCON%\symbols
MGC_TMPDIR C:\tmp

ANLG_IPC_PKG %SABER_FALCON%!\ipc

If AMPLE PATH or MGC_TYPE REGISTRY is already set for other
applications, add the following Saber paths:

Variable name Variable value

AMPLE_PATH old_AMPLE_PATH;%SABER_FALCON%\userware

MGC_TYPE_REGISTRY old_MGC _TYPE_REGISTRY;%SABER_FALCON%\
saber_rgy\registry\type_registry\saber.rgy

Important:
Do not set the ANLG_IPC_PKG variable on Windows.
The following sections describe:
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Verifying the Environment Variable Settings
Creating or Modifying a Location Map File
Loading the Saber and CosmosScope Icons
Verifying the Installation

Verifying the Environment Variable Settings

The environment variables described in the previous steps must be set for
noninteractive invocations of /bin/csh, as well as interactive invocations of
whatever shell you normally use. You cannot depend on noninteractive shells
inheriting the environment from interactive shells in either Design Architect or
Design Manager.

To ensure that the environment variables are correctly set,
1. Source your .cshrc file, create a new shell, or log out and log in.

2. To determine whether the environment is set correctly for interactive shells,
enter

)

% printenv

3. View the results to verify each environment variable that was described in
Step 7 on Installing the Software on page 20. Note that the variables are
expanded to their absolute paths.

4. To determine whether the environment is set correctly for a noninteractive C
shell, complete the following steps:

a. Using a text editor, create a file called my_csh_env in your current
directory containing the following lines:

#!/bin/csh
printenv > analogy csh env

MGC_TYPE REGISTRY old MGC_TYPE REGISTRY; \
%SABER FALCON%\saber rgy\registry\type registry \
\saber.rgy

b. Make the file executable by entering the following command at the shell
prompt:

% chmod 777 my csh env

c. To invoke Design Architect, enter

% da
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d. When the Design Architect session window appears, move the cursor
into the session window area, enter the following command:

$system("my csh env")
e. Exit Design Architect.

The previous steps create the analogy_csh_env file, which contains a
list of all environment variables in the noninteractive shell created with
the invocation of Design Architect. Check this file to ensure that the
environment variables are set correctly.

The following sections describe:
Creating or Modifying a Location Map File
Loading the Saber and CosmosScope Icons

Verifying the Installation

Creating or Modifying a Location Map File

The MGC_LOCATION_ MAP variable points to a location map file. You need to
modify that location map file. However, if you cannot modify the file (or don’t
want to), you can copy it to your local directory, modify it, and change the

MGC LOCATION MAP variable to point to your local copy. If the variable is not
defined, or if you do not know where to find a location map file, ask your system
administrator. The MGC_LOCATION MAP variable must point to the location
map file for both interactive and noninteractive shells, as outlined in the
previous section.

It is not sufficient to simply change the variable for your current shell. If you are
not using a location map, set MGC_LOCATION MAP to NO_MAP.

To create or modify a location map file,

1. If you need to create a location map file rather than copy an existing one,
place the following lines at the beginning of the file:

MGC_LOCATION MAP 2
(blank line)

2. Add the following soft prefixes to the location map file that you are either
creating or modifying:

$SABER MGC8 SYMBOLS
(blank line)

S SABER FALCON

(blank line)
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The Mentor Graphics environment requires that these entries be present in
the location map file to indicate that they are soft paths. You do not have to
specify hard paths for the location map entries because you already defined
them as environment variables, which override the corresponding location
map entries. However, if you prefer, you can omit the environment variable
specifications and instead specify the hard paths in the location map entries.
In either case, the location map entries must be included in the location map
file.

If you are using the Mentor Graphics Board Station products, a blank line
after the soft prefix name in the location map file can cause a fatal error.
Instead, you must specify a hard path for each soft prefix in the location map
file (except for the MGC_LOCATION_MAP_2 entry).

Initialize the startup file by logging out and logging back in.
The installation of the Frameway Integration software is now complete.

The following sections describe:

Loading the Saber and CosmosScope Icons

Verifying the Installation

Loading the Saber and CosmosScope Icons

To load the Saber and CosmosScope icons,

1.

Start Design Manager by using the following command:
% dmgr

When Design Manager is running, place the pointer in the Tools window and
click to activate the menu bar for the Tools window.

2. Add the Saber toolbox.

a. Select the Toolbox window by clicking in the border of the window.

b. Use the right mouse button to choose “View toolboxes.”

c. When the $MGC_HOME/toolbox icon appears, choose Edit > Add
Toolbox. A prompt bar appears on the lower-left side of the Toolbox
window.

d. Enter the following full path in the prompt bar and click OK:

saberfalcon/saber rgy/toolbox
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4.

In the preceding command, saberfalcon is the full path name to the
place where the $SABER FALCON environment variable resides. You
must either specify a hard path or SSABER FALCON must be defined in
the location map. If SSABER FALCON is defined in the location map, you
can use this soft name in the prompt bar entry.

A second toolbox named saberfalcon/saber_rgy/toolbox should now
appear in the Toolbox window.

Make sure the Saber and CosmosScope icons are visible in the Tools
window.

If the Tools window is not present inside the Design Manager window,
choose View > Tools. The icons for the Saber simulator and CosmosScope
should now be present in the Tools window, though you might have to scroll
through the window to find them.

Exit Design Manager.

The following section describes:

Verifying the Installation

Verifying the Installation

To verify that the Frameway Integration for Mentor Graphics is installed
correctly,

1.
2.
3.

Copy the $install_home/test/install/mentor directory to a local location.
Navigate to the newly created mentor directory.

Set the $SABER FALCON environment variable to point to your local copy
of the mentor directory. For example, if you are using the C shell, enter

% setenv SABER EXAMPLE your path/mentor
Invoke Design Architect by entering the following command:

% da
In Design Architect, click the Open Sheet icon to open the Open Sheet
dialog box.

In the Open Sheet dialog box, click the Navigator button, and in the resulting
List box, select the component you want to install.

The path to the component appears in the Component Name box of the
Open Sheet dialog box.
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In the Open Sheet dialog box, click OK.

Choose Check > Sheet. Close or minimize the “Check sheet” summary.
Choose File > Save Sheet.

Choose Saber > Netlist > Show Netlister Transcript.

You will be able to watch the netlister process in the resulting Netlister
Transcript window.

Choose Saber > Netlist > Start Netlister.
This starts the netlister.

After the netlist process has finished without any errors, close the Netlister
Transcript window.

Invoke Saber Guide by choosing Saber > Start Saber Guide.

Open the Saber Guide Transcript window by clicking the cmd Simulation
Transcript icon.

In the Saber Guide Transcript window, execute the following command:

<install.scs

The install.scs test program starts a simulation of a test circuit and then
loads the resultant plot files into CosmosScope.

Note:

The signals are not plotted in the graph window. To plot the same
signals in the graph window, use the scope plot command in the
install.scs command script.

If the commands that were executed by the install.scs script produced no
errors, the communication between the Mentor Graphics environment and
the Saber simulator is good. If you want to complete the test as was done in
checking the Saber simulator installation, see steps 7 and 8.

Exit Saber and Design Architect.

The following sections describe:

Troubleshooting a Frameway Integration for Mentor Graphics Installation

Installing the Saber Co-Simulation Interface With ModelSim

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation
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Setting Up the Software to Use a Remote System
Installing the Frameway Integration for eProduct Designer

Troubleshooting a Frameway Integration for
Mentor Graphics Installation
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If you followed the steps in the previous section, the environment for running
the Frameway Integration for the Mentor Graphics Falcon Framework should be
set up correctly. However, other factors can affect the operation of the software.
This section describes potential problems and suggests solutions.

PROBLEM 1

A schematic window is open and active but there is no Saber menu item in the
menu bar, no Saber Parts Gallery menu item, and no Saber or CosmosScope
icons in the palette.

Solution A

The ANALOGY SABER environment variable is not set to the value available. It
is also possible that either the variable or the value is misspelled. Setting this
environment variable correctly causes the Saber menu item to appear in the
menu bar even if the software has not been loaded.

Solution B

If the ANALOGY SABER environment variable is set correctly, other causes
might be that you executed an old version of Mentor Graphics software or that
some other third-party userware redefined the menu bar. If fixing these
potential causes does not solve your problem, contact Customer Support.

PROBLEM 2

A schematic window is open and active and there is a Saber menu item in the
menu bar, but there is no pull-down menu associated with it.

Solution

The userware has not been loaded into Design Architect. Enter the following
command:

% ls $SABER FALCON/userware
Check that the des_arch, base, and dve directories are listed and that there is

something in each of these directories. Also, make sure that the AMPLE PATH
environment variable contains the exact path that $SABER_FALCON/userware
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resolves to. For information on setting AMPLE PATH, see Step 7 in Installing
the Software on page 20.

PROBLEM 3

The first time you open a schematic window, error messages appear in the
Design Architect transcript window stating that $load_library failed in the
ipc.ample file.

Solution A

Check that the SANLG_IPC_PKG/lib/ample_ipc.dl file exists. If not, check the
ANLG _IPC_PKG environment variable setting, which is defined in
$install_home/bin/ai_setupmgc and aisetupmgc_csh.

Solution B

The library mentioned in the $load_library message must have execute
permissions. Check the permissions of ANLG_IPC_PKG/lib/ample_ipc.dl to
ensure that read and execute permissions exist for everybody.

PROBLEM 4

A netlist fails after you chose Saber > Netlist or Saber > Start Saber Guide and
ran an analysis.

Solution A

If a transcript window appears and shows the error message, fix the problem as
described. The transcript window shows the actual output of the current run.

Solution B

Check the transcript window carefully for the following message:
dvetos.exe: command not found

Check that your path environment variable points to the install_home/ai_bin
directory.

PROBLEM 5

The palette icons associated with the Saber products appear as letters or
numbers rather than pictures in Design Architect, or the Saber simulator tool
icons (Saber and CosmosScope) do not appear in the Design Manager Tools
window.

Solution

If the fonts still do not work after you rebuild them, execute the following
commands:
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o\°

o\°

xset fp+ $SABER FALCON/saber rgy/registry/fonts
xset fp+ $MGC HOME/registry/fonts

% xset fp rehash

This procedure should get your workstation to recognize the fonts. If you still
have problems, ensure that everyone has at least read and execute
permissions on all of the directories identified by the $SABER_FALCON/
saber_rgy/reqistry/fonts path.

The following sections describe:

Installing the Saber Co-Simulation Interface With ModelSim

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation
Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Installing the Saber Co-Simulation Interface With ModelSim
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Note:

The SNPSLMD LICENSE FILE or LM LICENSE FILE license
environment variable must be defined before you use a Frameway
Integration or Co-Simulation Interface option. For detailed instructions on
setting the license variable, see Installing Synopsys Tools.

Before you can correctly install the Saber/ModelSim interface, you must verify
the proper installation and operation of the ModelSim software and the Saber
software.

To correctly set up the Saber/ModelSim interface with the correct master-slave
relationships, perform the following operations:

®  For Solaris:
If ModelSim is master, enter

% setenv SABER MODELSIM install home/Saber/ \
bin/sabermti.so

% set path=(install home/ai bin $path)

% setenv LD LIBRARY PATH:$install home/ \
Saber/bin
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If Saber is master, enter

% setenv SABER MODELSIM install home/Saber/ \
bin/sabermti.so

$PATH must include the path to the ModelSim executable files.
"  For Windows:
1. Open the Environment Variables dialog box.

For example, on a Windows system, choose Start > Settings > Control
Panel > System > Advanced > Environment Variables.

2. Setthe SABER_MODELSIM variable to
install home\Saber\sabermti.dll

3. If ModelSim is the master, add the following line to the PATH variable:
install home\ai bin;install home\Saber\bin

4. PATH must include the path to the ModelSim executable files.

The following sections describe:

Installing the Frameway Integration for Cadence

Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Installing the Frameway Integration for Cadence

Note:

The SABER HOME variable and a license environment variable must be
defined before you install a Frameway Integration or Co-Simulation Interface
option.

Set the SABER HOME environment variable as follows:

% setenv SABER HOME install home/Saber

To set the SNPSLMD LICENSE FILE or LM LICENSE FILE license
environment variable, see Installing Synopsys Tools.
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Before you can correctly install the Frameway Integration for the Cadence
Design Il Environment, you must verify the proper installation and operation of
the partner software and the Saber software. To make these checks,

1. Test the Design Framework |l software installation.

a. Invoke Design Framework Il by entering the appropriate command for
your system. Your invocation command will be similar to one of the
following examples: icms, ictb, msfb, or icds.

The Frameway Integration for Design Framework |l is compatible with
the Cadence Composer and Analog Artist 4.X.

b. Exit Design Framework Il.
Note:

If you are unable to invoke Design Framework ll, see the
appropriate Cadence installation manual for more information.

Verify that the Saber simulator is installed and works correctly.
Set the library environment variables.

Set or modify the path to your LD LIBRARY PATH (Sun) variable in your
.cshrc file. A script is provided to automate this procedure. Simply enter the
following lines at the command-line prompt:

% ed 's/$0/ai_setlibpath/’ $SABER HOME/bin/ \
ai setlibpath > ! /tmp/my setlibpath
% source /tmp/my setlibpath

4. (Optional) If you will be using a partner simulator with the Saber simulator,
verify that the Verilog simulator is installed for use as a partner simulator.
5. Load the Frameway Integration software.

If you did not load the Frameway Integration for the Cadence Design
Framework Il at the time the Saber simulator was installed, do so now.

6. Install the necessary license.
a. Add the license information to the license file.

b. If needed, install the licenses for the Saber/Verilog Co-Simulation option
and the Digital Simulation option.

7. Create the directories.

You must create a directory named local in cadence standard directory/
tools/dfll and create several directories within the local directory.
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Make this directory your current (working) directory. For example, on a
Sun system enter

[

% cd $cds _root/tools/dfII

Create this directory, if it does not already exist, as follows:

[

% mkdir local

Create the following directories in the local directory if they do not
already exist:

o\°

cd local

mkdir hnl

mkdir -p si/caplib
cd si/caplib

o\° o\

o\°

Copy the following files to the caplib directory:

Copy the si_saber_cds.il file to a Saber.il file in the caplib directory and
change permissions, as follows:

% cp $SABER HOME/framework/artist/skill/ \
si saber cds.il cadence standard directory/ \
tools/dfll/local/si/caplib/Saber.il

% chmod 755 cadence standard directory/tools/df1ll/ \
local/si/caplib/Saber.il

Copy the si_saberHDL _cds.il file to a SaberHDL.il file in the caplib
directory and change permissions, as follows:

% cp $SABER HOME/framework/artist/skill/ \
si saberHDL cds.il cadence install dir/ \
tools/dfll/local/si/caplib/SaberHDL.1il

% chmod 755 cadence install dir/tools/dfll/ \
local/si/caplib/SaberHDL.il

Copy the following files to the hnl directory:

Copy the hnl_saber_cds.il file to a Saber.il file in the hnl directory and
change permissions, as follows:

% cp $SABER HOME/framework/artist/skill/ \
hnl saber cds.il cadence standard directory/ \
tools/dfII/local/hnl/Saber.il

% chmod 755 cadence standard directory/tools/dfII/ \
local/hnl/Saber.il

Copy the hnl_saberHDL_cds.il file to a SaberHDL.il file in the hnl
directory and change permissions, as follows:
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% cp $SABER HOME/framework/artist/skill/ \
hnl saberHDL cds.il cadence install dir/ \
tools/dfII/local/hnl/SaberHDL.il

% chmod 755 cadence install dir/tools/dfII/ \
local/hnl/SaberHDL.il

Enter cd to return to your home directory.
Edit your cds.lib file to add symbol information.
The cds.lib file is a part of the Cadence Design Framework Il software.

* Edit the cds.lib file to include the path to the Frameway symbols in the
definition of the library search path. You do this by using ASCII files. For
example,

DEFINE SaberLib $SABER HOME/framework/artist/symbols/
SaberLib

DEFINE basic $CDS HOME/tools/dfII/etc/cdslib/basic
INCLUDE /.../other/.../cds.1lib

These files can call other cds.lib files so that system files can be resident
in a location and referred to with an INCLUDE statement. Environment
variables can be used as shown.

If the cds.lib file is in your local directory, it is used. Otherwise the ~/
cds.lib file is used. By using a local cds.lib file, you can set design-
specific search paths.

10. In the Cadence Design Framework Il directory, create a MAST file
containing initial configuration information.

a. To create the file, use an ASCII editor, such as vi, that does not insert
formatted text and enter
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//Revision 4

//NOTE

// Default template for MAST

// Note:

// Please remember to replace Top Cell

// Library, Cell, and View fields with the
// actual names used by your design.
//END_NOTE

config mast;
design myLib.myCell:myView;

viewlist mast, schematic, symbol;
stoplist mast, symbol;

endconfig

b. Place the file in the following directory:
$CDS_HOME/tools/dfll/local/hierEditor
c. Name the file MAST and save it.
11. Copy the .artistSaberDefaults.il file.

The .artistSaberDefaults.il file sets the defaults for menus and dialog boxes
in Design Framework Il. You can copy this file into your home directory and
modify it to set the defaults you prefer for general use, or you can copy it into
a particular project directory and then modify it to set the defaults to be used
for that project.

If more than one .artistSaberDefaults.il file exists on your system, the
.artistSaberDefaults.il file in your current (working) directory is used if it
exists. If not, the .artistSaberDefaults.il file in your home directory is used.

a. Make your home directory or a project directory your working directory.

b. To copy the file to your working directory, enter

% cp $SABER HOME/framework/artist/ dotfiles/
.artistSaberDefaults.il .

Enter the code all on one line. The space and period at the end are
important.

c. To change the default working directory for the Cadence Design
Framework Il software, which is set by the .artistSaberDefaults.il file,
edit the file as follows:
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System administrators: To change the sitewide .artistSaberDefaults.il
file, edit the file in $SABER_HOME/framework/artist/dotfiles.

Individual users: Edit your local copy of the .artistSaberDefaults.il file.

e Set the saber_simRunDir template to point to the specific directory you
want.

Or you can set

saber simRunDir = getWorkingDir ()

e Choose Saber > Set Working Directory and specify the directory you
want.

* Use a UNIX environment variable called SABER DEFAULT to set the
path to the .artistSaberDefaults.il file.

If this path is set and the file is present, this file will be loaded. Otherwise
the .artistSaberDefaults.il file will be loaded from the home directory or
the working directory. For example, suppose you set the variable as
follows:

setenv SABER DEFAULT /homes/myfile/latest

If an .artistSaberDefaults.il file exists in /homes/myfile/latest, it will be
used instead of any other files present on your system.

12. Load the new ~/.cdsinit file.

To access the integration to Cadence 5.0 or 5.1, you need to create a new
.cdsinit file and install it in each user’s home directory. Use a text editor, such
as vi, that does not insert formatted text.

The contents of the .cdsinit file for this release are different from the contents
in previous versions. An example of the new file contents follows:
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load (strcat (getShellEnvVar ("install home")\
"/framework/artist/skill/analogy.il "))

load (strcat (getShellEnvVar ("install home")\
"/framework/artist/skill/analogyReg.il1")) ;

load (strcat (getShellEnvVar ("install home")\
"/framework/artist/skill/viewgen.il "))

analogy menu creation()

printf ( "Done with startup
initialization.\n" )

The analogyReg.il and viewgen.il files are necessary only if you are using
the Frameway Integration for Cadence text views feature. These files are
used to register the MAST view type. The MAST views must be registered
before you can create them.

13. Register the MAST views by performing the following steps:

a. Go to the data.reg file, which is located at
$SABER_HOME/framework/artist/skill

b. Do one of the following:

e Put data.reg into the home directory.

* Follow the instructions in data.reg to split it into these files:
cds_install/share/cdssetup/registry/data/mast.reg
cds_install/share/cdssetup/registry/data/anlg_verilog.reg
cds_install/share/cdssetup/registry/data/snps_vhdlams.reg
cds_install/share/cdssetup/registry/tool/mastEditor.reg
cds_install/share/cdssetup/registry/tool/anlg_verilog.reg
cds_install/share/cdssetup/registry/tool/snps_vhdlams.reg

c. Load the analogyReg.il and viewgen.il files with analogy.il. Add a line to
your .cdsinit file that will load all three files.

The viewgen.il file and the analogyReg.il file, which contains the trigger
functions, are located at

$SABER_HOME/framework/artist/skill
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To create a MAST view that uses the trigger functions found in
analogyReg.il, follow the procedures on creating text views in Cadence
in the Analyzing Designs Using Saber for the Cadence Design
Framework Il manual.

14. Verify that the menus have been installed correctly, and complete the
installation.

a.

Copy the $SABER_HOME!/test/install/cadence directory to a local
location.

Edit your cds.lib file to include the path of the cadence/install library.

Invoke Design Framework Il by entering the appropriate command for
your version of the software (for example, icde, icds, icms, asicfe,
layout, layoutPlus, icca, asicpr, Or icfb).

The Saber menu item should appear on the menu bar in the schematic
window.

Choose File > Open. The Open File dialog box appears.
In the Open File dialog box,

Select Library Name > install.

Then select Cell Name > install.

Then select View Name > schematic.

Click OK.

The schematic window should appear with no errors. Check and save
the design if necessary.

In the schematic window,
Choose Saber > Set Working Directory.

In the resulting Project Information dialog box, check that the Project
Directory box is set to your_path/cadence.

Click OK.
In the schematic window, select Saber > Netlist > Start Netlister.

This starts the netlister. A simulation window appears that contains the
netlister transcript.

After the netlist process has finished without errors, close the simulation
window.

Invoke Saber Guide by choosing Saber > Start Saber Guide.
The design is automatically loaded in Saber.
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k. Open the Saber Guide transcript window by clicking the Simulation
Transcript icon.

I.  Inthe Saber Guide transcript window, choose File > Load Command
File.

m. Navigate to your_path/cadence and load the install.scs file.

This will execute the commands in the install.scs file. The install.scs test
program starts a simulation of a test circuit and then loads the resultant
plot files into CosmosScope.

If the commands that were executed by the install.scs script produced
no errors, the communication between the Cadence Design Framework
Il and the Saber simulator is good.

n. Exit Saber and Design Framework .
The following sections describe:
Installing the Saber Co-Simulation Interface With Verilog

Troubleshooting the Saber Co-Simulation Interface With Verilog
Installation

Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer

Installing the Saber Co-Simulation Interface With Verilog

Note:

The SNPSLMD LICENSE FILE or LM_LICENSE FILE license variable
must be defined before you install a Frameway Integration or Co-Simulation
Interface option. See Installing Synopsys Tools.

To simulate mixed-signal designs by using Verilog-XL as a partner simulator
with the Saber simulator, you will need the following licenses:

® Licenses for the Saber/Verilog Co-Simulation Interface (SABER/
VERILOG_MM)

=  Alicense from Cadence Design Systems for the Verilog-XL simulator
To build the Verilog executable file, you need to run the vconfig utility provided

by Cadence.
Set or modify the path to your LD _LIBRARY PATH (Sun) variable in your .cshrc
file.
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See the instructions for linking Verilog executable files in the Cadence
documentation.

To install your Saber/Verilog software,

1.

Install the software.

The Saber/Verilog Co-Simulation Interface software is loaded at the same
time you load the Saber integrated suite of products.

Install the licenses.

e If you have not yet installed a license file for your software, you can
install the license for the SABER/VERILOG MM option as a part of the
software installation procedure.

e If you have already installed a license file for your software, update that
file by adding the SABER/VERILOG_MM license.

Verify that the Saber simulator is installed and works correctly.
Install the Verilog-XL simulator license.

Obtain a Verilog-XL simulator license from Cadence Design Systems, and
complete any installation instructions provided with the license.

Test that the Verilog-XL simulator is installed correctly.

* Invoke the Verilog-XL simulator by entering the appropriate command
for your system.

If you cannot invoke the Verilog-XL simulator, see the appropriate
Cadence Design Systems installation manual for more information.

*  Exit the Verilog-XL simulator.
(Optional) Create a configuration file for socket communication.

By default, pipe communication mode is used with the Saber simulator. If
you want to use socket communication with Saber Guide, you must create
a config.vmx file as follows:

a. Copy the $install_home/bin/config.vmx file to your working directory.

If you save the config.vmx file to a directory other than your working
directory, you must modify your $install_home/bin/verilog.scf file
accordingly.

b. Make no other changes to the verilog.scf file.
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The version of the verilog.scf file provided with the software must be
used when you use the Saber/Verilog software. Check that no other
versions are present in the data search path ahead of this file.

7. Create the Verilog executable file.

Follow Cadence instructions for invoking vconfig. The instructions likely
involve adding a directory to your PATH environment variable, for example,
$CDS_ROOQT/tools/bin.

a. When vconfig asks, “What do you want to name the Verilog_XL target?,
use the default: verilog.

b. When vconfig asks, “Do you want to include Verilog Mixed-Signal
Interface?,” answer YES.

c. When vconfig asks for the names of additional files to be loaded, enter
a single period (.).

d. Create the Verilog executable file by entering

[

% al make verilog

For more information about the command, enter

Q

% al make verilog -h

Install the Verilog-XL executable file in the desired directory.
(Optional) Change the invocation name for the Saber/Verilog simulator.

You can set the invocation name verilog to an ASCII string of your choosing
in the invocation_name.scf file.

a. Use an ASCII text editor to open the $install_home/bin/
invocation_name.scf file.

b. Change the invocation name item from verilog to an ASCII string (for
example, verilog.scf).

The following section describes:
Troubleshooting the Saber Co-Simulation Interface With Verilog Installation
Setting Up the Software to Use a Remote System

Installing the Frameway Integration for eProduct Designer
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This section describes a series of potential problems and suggests solutions.
PROBLEM 1

You get an error while creating the Verilog executable file.

Solution A

Usually, this error is due to missing or incorrect versions of the C or C++
compilers.

Solution B

Some releases of Cadence's vconfig might produce a script that, when run,
produces undefined symbols:

1d: Undefined symbol
bcopy

getdtablesize

getwd

These symbols are undefined because a Cadence library, virtuous.a, is missing
from the vconfig output script. The library will be included if you answer the
vconfig questions in a particular way. In general, those questions that have v as
their default answer result in the inclusion of virtuous.a. Contact Cadence for
details.

PROBLEM 2

When you attempt to operate remotely, the error message “remote_host_name:
remote_host_name: cannot open” is displayed.

Solution

The restricted shell version of the rsh command was executed instead of the
remote shell version. Change your PATH environment variable to include the
path to the remote shell version of the rsh command. This executable file is
typically located in either /usrucb or /usr/bin. This directory should appear in
the search path ahead of any directories containing, or pointing to, the
restricted shell version of the rsh command.

PROBLEM 3

When you attempt to operate remotely, the error message “permission denied”
is displayed.
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Solution
Complete the following steps:
" Login to the remote system.

= Create or modify a file named .rhosts in your home directory on the remote
system. Include in the file a line that contains the name of your local system.
To view man page information about the .rhosts file, enter one or both of the
following commands:

man login
man rsh

PROBLEM 4
You are unable to start Verilog-XL from the Saber simulator.
Solution A

The Verilog-XL executable file does not have execute permission. Change the
permission on the executable file, using the command

[)

% chmod +x verilog pathname

where verilog_pathname is the path to Verilog-XL, including the executable file.
Solution B

The Verilog-XL executable file is not found in the PATH variable. Change the
path definition to include the directory where the Verilog-XL executable file
resides, as follows:

set PATH = (verilog directory S$PATH)

where verilog_directory is the path to the directory containing the Verilog-XL
executable file.

PROBLEM 5
Verilog-XL starts but exits immediately with the message

***The partner simulator exited unexpectedly***

Solution A

Verilog-XL cannot find the license file. Examine the Verilog-XL output file
verilog.log. Look for a line in the log file similar to this one:

Error! ERROR (LM -24): can’t find license file.
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If such an error is found, make sure the license variable
(SNPSLMD LICENSE FILE or LM LICENSE FILE) points to the appropriate
license file. Modify the environment variable if necessary. For example,

setenv LM _LICENSE FILE "...:verilog license file"

where verilog_license_file is the path to the Verilog-XL license file.
Solution B

The SNPSLMD LICENSE FILE or LM_LICENSE FILE license environment
variable is pointing to a Verilog-XL license file that is invalid or has expired.
Examine the Verilog-XL output file verilog.log. Look for a line in the log file
similar to this one:

Error! ERROR (LM -35): license for feature has expired.

If such an error is found, obtain a valid license file from Cadence Design
Systems, install the license file, and set the license environment variable
accordingly.

PROBLEM 6

When you invoke the Saber/Verilog software with the Verilog-XL simulator
running on a remote host, the Verilog-XL simulator starts but exits immediately
with the following error message:

The partner simulator exited unexpectedly

Solution A

There is no permission to execute the shell on the remote host. Verify that you
have permission to execute an rsh command on the remote host by entering

% rsh host 'ls' (Sun machines)

where host is the name of the remote host. If you are unable to execute a
remote shell, contact your system administrator to arrange for you to execute
remote shells on the remote host.

Solution B

The remote working directory is invalid. Verify that the working directory on the
remote host is valid by entering

% rsh host 'cd remote directory'
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where host is the name of the remote host, and remote_directory is the
directory where the Verilog-XL simulator will be run on the remote host.

Correct the remote working directory as necessary to ensure a valid path name
on the remote host, either by modifying the Saber Guide invocation command

line (-pwd option) or by modifying the verilog.scf file (where the remote working
directory can be specified).

Solution C

The Verilog-XL executable file cannot be found in the path on the remote
system. Verify that the Verilog-XL executable file can be found on the remote
system by entering

% rsh host 'cd remote directory; verilog -s verilog file'

where host is the name of the remote host, remote_directory is the directory
where the Verilog-XL executable file will be run on the remote host, and
verilog_file is the name of Verilog-XL input file.

Change permissions on the Verilog-XL executable file, or modify the path so
that the Verilog-XL executable file can be found on the remote system.

The following sections describe:
Setting Up the Software to Use a Remote System
Installing the Frameway Integration for eProduct Designer

Setting Up the Software to Use a Remote System

To set up your Saber/Verilog software to run on a remote system,
1. Set up a user account on the remote system.

Your system administrator might need to do this for you.
2. Test that you can execute a remote shell locally.

* To test on other systems, enter

% rsh remote host name ls

The following section describes:
Installing the Frameway Integration for eProduct Designer
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Installing the Frameway Integration for
eProduct Designer

To complete the eProduct Designer Frameway installation, follow these steps:

1.

DIR

Install the Mentor Graphics eProduct Designer software and verify the
installation.

Select the eProduct Designer option during Saber installation to install the
Frameway software for eProduct Designer.

Copy the viewdraw.ini file, located in the
install_home\Saber\framework\viewlogic\standard directory, to your
%HOME% directory(Project directory).

Modify the Saber symbol path names in the viewdraw.ini file to be absolute
path names. Replace the $(SABER_HOME) path name in each of the Saber
symbol library path names with the actual path to the place where the Saber
symbol files reside.

For example, if the location of install_home is
c:\Synopsys\X-2005.09, change the symbol library path name from

DIR [mr] $ (SABER_HOME) /framework/viewlogic/symbols/beta
(shr beta)

to

[rm] c:\Synopsys\X-

2005.09\Saber\framework\viewlogic\symbols\beta /

48

(shr beta)

5.

Modify the WDIR, PATH, and license environment variables as follows:

a. Start the System program by choosing Start > Settings > Control Panel
> System > Environment tab.

b. Add these paths to the WDIR variable:

install home\Saber\framework\viewlogic\standard
install home\ai bin

install home\Saber\bin
install_home\ePD2007\2007IND\SDD HOME\standard
-- ePD Installation
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For example the following is a snapshot of the WDIR setting if Saber is
installed in C:\Synopsys\A-2007.12-SP2 and eProduct Designer is installed
in C:\MentorGraphics:
C:\Synopsys\A-2007.12-
SP2\Saber\framework\viewlogic\standard;C:\Synopsys\A-

2007.12-SP2\ai bin;C:\Synopsys\A-2007.12-
SP2\Saber\bin;C:\MentorGraphics\2005BST\SDD HOME\standard

c. Add these paths to the PATH variable:

install home\ai bin
install home\Saber\bin

6. Modify the license environment variable (SNPSLMD LICENSE FILE or
LM _LICENSE_ FILE) to include the location of the Synopsys license file.
You can use path or port@hostname syntax. For example,

27000@serverl;C:/Synopsys/license.lic

7. Start DxDesigner and open a design. The Saber menu should be in the
menu bar to the left of the Help menu.

Installing the Frameway Integration for Zuken CR-5000 System
Designer

To complete the Zuken System Designer Frameway installation, follow these
steps:

1. Install the Zuken CR-5000 System Designer software and verify the
installation.

2. Select the Zuken Frameway option during Saber installation to install the
Frameway software for Zuken System Designer.

3. Ensure that thte CR5_PROJECT_ ROOT environment variable points to the
integration files, for example:

CR5_PROJECT ROOT = C:\ZDWest\CR5 PROJECT ROOT

4. Ensure that the SABER DATA PATH environment variable points to the
Saber installation, for example:

SABER DATA PATH = C:\synopsys\B-2008.09

Note: B-2008. 09 indicates the current version of Saber Installation.
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5. Ensure that the ZUKENFW environment variable points to the directory
containing the “zukenfw” program. For example:

C:\Synopsys\B-2008.09\ai bin

This variable is used in the menu files (mainmenu.scm) to locate the
zukenfw program.

6. Ensurethatthe LM LICENSE FILE environment variable includes the
licenses for Zuken System Designer. For example:

LM LICENSE FILE = 7770@stoat

7. Copy netlister files saber sitk.frm, sabersketch sitk.frm and
saberguide sitk.frmfrom Saber\framework\zuken to
C:\ZDWest\CR5 PROJECT ROOT\zds\etc

8. Reboot the machine and start Zuken System Designer. A Saber menu
option should appear in the System Designer pull-down menus.
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